搜索
虾皮社区 首页 网络建站 Discuz二次开发 查看内容

Discuz应用中心安装插件提示“数据下载错误(105)”的解决办法

2018-10-11 17:18| 发布者: happyxp| 查看: 92| 评论: 0

摘要: 近期很多用户在应用中心安装应用,提示105错误,大部分是阿里云的服务器,PHP 5.3.28、PHP5.3.29等。通过常规的方法排查后,仍然不能解决问题,官方给出的说明是PHP问题,升级PHP即可,经过测试,确实是PHP问题,升 ...
近期很多用户在应用中心安装应用,提示105错误,大部分是阿里云的服务器,PHP 5.3.28、PHP5.3.29等。

通过常规的方法排查后,仍然不能解决问题,官方给出的说明是PHP问题,升级PHP即可,经过测试,确实是PHP问题,升级PHP可以解决。

但不是所有用户都知道如何升级,经排查,锁定了引起php5.3执行错误的代码,在大量测试下找到了一种特殊的偏方,解决办法如下:

打开 source\admincp\admincp_cloudaddons.php
找到 
if($md5 != md5_file($file)) {
修改为
if('s'.$md5 != 's'.md5_file($file)) {
问题解决。
为什么要这样子修改,其实我也不知道,网上给出的解决方案就是这样,如果你那边升级php版本这个不好用了,可以尝试再改回去。

鲜花

握手

雷人

路过

鸡蛋

相关阅读

最新评论

虾皮社区,成立十年了!

站长自己也搞不懂想做个什么,反正就是一直在努力的做!

Copyright © 2007-2018 xp6.org Powered by Discuz

QQ|小黑屋|手机版|Archiver|虾皮社区 ( 鲁ICP备13006813号 )

鲁公网安备 37021102000261号

 
返回顶部